<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Ugandans react to Meghan, Harry explosive interview | Kampala Sun</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://kampalasun.co.ug/xmlrpc.php" />
    <meta property="og:image" content="https://kampalasun.co.ug/wp-content/uploads/2021/03/prince-harry-meghan-oprah.jpg" /><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Kampala Sun &raquo; Feed" href="https://kampalasun.co.ug/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kampala Sun &raquo; Comments Feed" href="https://kampalasun.co.ug/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kampala Sun &raquo; Ugandans react to Meghan, Harry explosive interview Comments Feed" href="https://kampalasun.co.ug/2021/03/10/ugandans-react-to-meghan-harry-explosive-interview/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/kampalasun.co.ug\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.6"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://kampalasun.co.ug/wp-includes/css/dist/block-library/style.min.css?ver=5.3.6' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://kampalasun.co.ug/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=9e241c87ee8782e8f19bb886a935e653' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Fira+Sans%3A400%2C100%2C100italic%2C200%2C200italic%2C300%2C300italic%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic%7COpen+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%2C100%2C100italic%2C200%2C200italic%2C300%2C500%2C500italic%2C700italic%2C800%2C800italic%2C900%2C900italic%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900%2C100%2C100italic%2C200%2C200italic%2C300italic%2C600%2C600italic%2C700italic%2C800%2C800italic%2C900italic&#038;ver=9.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://kampalasun.co.ug/wp-content/themes/Newspaper/style.css?ver=9.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='https://kampalasun.co.ug/wp-content/themes/Newspaper/includes/demos/gossip/demo_style.css?ver=9.1' type='text/css' media='all' />
<script type='text/javascript' src='https://kampalasun.co.ug/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://kampalasun.co.ug/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://kampalasun.co.ug/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://kampalasun.co.ug/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://kampalasun.co.ug/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Mr.Eezy on the spot over stolen song' href='https://kampalasun.co.ug/2021/03/10/mr-eezy-on-the-spot-over-stolen-song/' />
<link rel='next' title='GNL eyes tourism ambassadorial post' href='https://kampalasun.co.ug/2021/03/10/gnl-eyes-tourism-ambassadorial-post/' />
<meta name="generator" content="WordPress 5.3.6" />
<link rel="canonical" href="https://kampalasun.co.ug/2021/03/10/ugandans-react-to-meghan-harry-explosive-interview/" />
<link rel='shortlink' href='https://kampalasun.co.ug/?p=10314' />
<link rel="alternate" type="application/json+oembed" href="https://kampalasun.co.ug/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkampalasun.co.ug%2F2021%2F03%2F10%2Fugandans-react-to-meghan-harry-explosive-interview%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://kampalasun.co.ug/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkampalasun.co.ug%2F2021%2F03%2F10%2Fugandans-react-to-meghan-harry-explosive-interview%2F&#038;format=xml" />
			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/kampalasun.co.ug\/wp-admin\/","wpRestNonce":"7e37a7d8c2","wpRestUrl":"https:\/\/kampalasun.co.ug\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/"};
			</script>
			<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
    
<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<script type="application/ld+json">
                        {
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "https://kampalasun.co.ug/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://kampalasun.co.ug/category/celebs/",
                                "name": "Celebs"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://kampalasun.co.ug/category/celebs/hollywood/",
                                "name": "Hollywood"                                
                            }
                        },{
                            "@type": "ListItem",
                            "position": 4,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://kampalasun.co.ug/2021/03/10/ugandans-react-to-meghan-harry-explosive-interview/",
                                "name": "Ugandans react to Meghan, Harry explosive interview"                                
                            }
                        }    ]
                        }
                       </script>
<!-- Button style compiled by theme -->

<style>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</style>

	<style id="tdw-css-placeholder"></style>    <!-- Global site tag (gtag.js) - Google Analytics -->
    <script async src="https://www.googletagmanager.com/gtag/js?id=UA-658465-20"></script>
    <script>
      window.dataLayer = window.dataLayer || [];
      function gtag(){dataLayer.push(arguments);}
      gtag('js', new Date());
    
      gtag('config', 'UA-658465-20');
    </script>
   
    <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
    <script>
      window.googletag = window.googletag || {cmd: []};
      googletag.cmd.push(function() {
        googletag.defineSlot('/16375024/Tks300x250', [300, 250], 'div-gpt-ad-1565014161751-0').addService(googletag.pubads());
        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
      });
    </script>
    
    <!-- Opinion polls div and its css. Start-->
    
<script type="text/javascript">
	jQuery(document).ready(function($){
		$('.close-div').click(function(){
			$('.overall-div').css('display', 'none');
		});
	});
	
	
</script>
    
</head>

<body class="post-template-default single single-post postid-10314 single-format-standard ugandans-react-to-meghan-harry-explosive-interview global-block-template-1 td-gossip tdb_template_29 elementor-default td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/kampalasun/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/the_kampala_sun?lang=en" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu" class="td-mobile-main-menu"><li id="menu-item-35" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-35"><a href="https://kampalasun.co.ug/">Home</a></li>
<li id="menu-item-36" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-36"><a href="#">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="https://kampalasun.co.ug/category/celebs/beauty/">Beauty</a></li>
	<li class="menu-item-0"><a href="https://kampalasun.co.ug/category/celebs/entertainment/">Entertainment</a></li>
	<li class="menu-item-0"><a href="https://kampalasun.co.ug/category/celebs/hollywood/">Hollywood</a></li>
	<li class="menu-item-0"><a href="https://kampalasun.co.ug/category/celebs/modelling/">Modelling</a></li>
	<li class="menu-item-0"><a href="https://kampalasun.co.ug/category/celebs/music/">Music</a></li>
</ul>
</li>
<li id="menu-item-37" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-37"><a href="#">Entertainment<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-40" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40"><a href="https://kampalasun.co.ug/category/style/">Celebrities</a></li>
	<li id="menu-item-41" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41"><a href="https://kampalasun.co.ug/category/travel/">Gossip</a></li>
	<li id="menu-item-42" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42"><a href="https://kampalasun.co.ug/category/weird/">Lifestyle</a></li>
	<li id="menu-item-286" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-286"><a href="https://kampalasun.co.ug/category/celebs/music/">Trending</a></li>
	<li id="menu-item-285" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-285"><a href="https://kampalasun.co.ug/category/travel/">Travel</a></li>
	<li id="menu-item-287" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-287"><a href="https://kampalasun.co.ug/category/whats-hot/">Wierd</a></li>
</ul>
</li>
<li id="menu-item-39" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-39"><a href="#">Events<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-288" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-288"><a href="https://kampalasun.co.ug/category/featured/">Photos</a></li>
	<li id="menu-item-289" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-289"><a href="https://kampalasun.co.ug/category/featured/">Videos</a></li>
</ul>
</li>
<li id="menu-item-38" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38"><a href="#">Sports</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://kampalasun.co.ug/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap" class="td-theme-wrap">
    
        <!--
Header style 7
-->


<div class="td-header-wrap td-header-style-7 ">
    
    
    <div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap td-header-gradient ">
            <div class="td-container td-header-row td-header-main-menu">
                <div class="td-header-sp-logo">
                                <a class="td-main-logo" href="https://kampalasun.co.ug/">
                <img src="https://kampalasun.co.ug/wp-content/uploads/2019/06/Sun-Logo-1-300x183.png" alt=""/>
                <span class="td-visual-hidden">Kampala Sun</span>
            </a>
                        </div>
                    
    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://kampalasun.co.ug/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>

<div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
        		<a class="td-mobile-logo td-sticky-disable" href="https://kampalasun.co.ug/">
			<img src="https://kampalasun.co.ug/wp-content/uploads/2019/06/Sun-Logo-1-300x183.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-disable" href="https://kampalasun.co.ug/">
			<img src="https://kampalasun.co.ug/wp-content/uploads/2019/06/Sun-Logo-1-300x183.png" alt=""/>
		</a>
	    </div>
    <div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-35"><a href="https://kampalasun.co.ug/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-mega-menu menu-item-36"><a href="#">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_6049141dce4f6_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_1_6049141dce4f6" ><script>var block_td_uid_1_6049141dce4f6 = new tdBlock();
block_td_uid_1_6049141dce4f6.id = "td_uid_1_6049141dce4f6";
block_td_uid_1_6049141dce4f6.atts = '{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"4","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_1_6049141dce4f6_rand","tdc_css_class":"td_uid_1_6049141dce4f6_rand","tdc_css_class_style":"td_uid_1_6049141dce4f6_rand_style"}';
block_td_uid_1_6049141dce4f6.td_column_number = "3";
block_td_uid_1_6049141dce4f6.block_type = "td_block_mega_menu";
block_td_uid_1_6049141dce4f6.post_count = "4";
block_td_uid_1_6049141dce4f6.found_posts = "1782";
block_td_uid_1_6049141dce4f6.header_color = "";
block_td_uid_1_6049141dce4f6.ajax_pagination_infinite_stop = "";
block_td_uid_1_6049141dce4f6.max_num_pages = "446";
tdBlocksArray.push(block_td_uid_1_6049141dce4f6);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_1_6049141dce4f6" id="td_uid_2_6049141dd42d1" data-td_block_id="td_uid_1_6049141dce4f6" data-td_filter_value="" href="https://kampalasun.co.ug/category/celebs/">All</a><a class="mega-menu-sub-cat-td_uid_1_6049141dce4f6"  id="td_uid_3_6049141dd4321" data-td_block_id="td_uid_1_6049141dce4f6" data-td_filter_value="5" href="https://kampalasun.co.ug/category/celebs/beauty/">Beauty</a><a class="mega-menu-sub-cat-td_uid_1_6049141dce4f6"  id="td_uid_4_6049141dd4366" data-td_block_id="td_uid_1_6049141dce4f6" data-td_filter_value="6" href="https://kampalasun.co.ug/category/celebs/entertainment/">Entertainment</a><a class="mega-menu-sub-cat-td_uid_1_6049141dce4f6"  id="td_uid_5_6049141dd43a2" data-td_block_id="td_uid_1_6049141dce4f6" data-td_filter_value="7" href="https://kampalasun.co.ug/category/celebs/hollywood/">Hollywood</a><a class="mega-menu-sub-cat-td_uid_1_6049141dce4f6"  id="td_uid_6_6049141dd43dc" data-td_block_id="td_uid_1_6049141dce4f6" data-td_filter_value="8" href="https://kampalasun.co.ug/category/celebs/modelling/">Modelling</a><a class="mega-menu-sub-cat-td_uid_1_6049141dce4f6"  id="td_uid_7_6049141dd4416" data-td_block_id="td_uid_1_6049141dce4f6" data-td_filter_value="9" href="https://kampalasun.co.ug/category/celebs/music/">Music</a></div></div><div id=td_uid_1_6049141dce4f6 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://kampalasun.co.ug/2021/03/10/uganda-music-industry-must-embrace-digital-avenues-in-order-to-increase-revenues/" rel="bookmark" class="td-image-wrap" title="Uganda Music Industry must  embrace digital Avenues in order to increase revenues"><img width="218" height="150" class="entry-thumb" src="https://kampalasun.co.ug/wp-content/uploads/2021/03/IMG-20210309-WA0035-218x150.jpg" srcset="https://kampalasun.co.ug/wp-content/uploads/2021/03/IMG-20210309-WA0035-218x150.jpg 218w, https://kampalasun.co.ug/wp-content/uploads/2021/03/IMG-20210309-WA0035-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Uganda Music Industry must  embrace digital Avenues in order to increase revenues"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://kampalasun.co.ug/2021/03/10/uganda-music-industry-must-embrace-digital-avenues-in-order-to-increase-revenues/" rel="bookmark" title="Uganda Music Industry must  embrace digital Avenues in order to increase revenues">Uganda Music Industry must  embrace digital Avenues in order to&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://kampalasun.co.ug/2021/03/10/nince-henry-clarifies-on-suicide-claims/" rel="bookmark" class="td-image-wrap" title="Nince Henry clarifies on suicide claims"><img width="218" height="150" class="entry-thumb" src="https://kampalasun.co.ug/wp-content/uploads/2021/03/hhh-218x150.jpg" srcset="https://kampalasun.co.ug/wp-content/uploads/2021/03/hhh-218x150.jpg 218w, https://kampalasun.co.ug/wp-content/uploads/2021/03/hhh-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Nince Henry clarifies on suicide claims"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://kampalasun.co.ug/2021/03/10/nince-henry-clarifies-on-suicide-claims/" rel="bookmark" title="Nince Henry clarifies on suicide claims">Nince Henry clarifies on suicide claims</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://kampalasun.co.ug/2021/03/10/gnl-eyes-tourism-ambassadorial-post/" rel="bookmark" class="td-image-wrap" title="GNL eyes tourism ambassadorial post"><img width="218" height="150" class="entry-thumb" src="https://kampalasun.co.ug/wp-content/uploads/2021/03/Ernest-Nsimbi-aka-GNL-Zamba-218x150.jpg" srcset="https://kampalasun.co.ug/wp-content/uploads/2021/03/Ernest-Nsimbi-aka-GNL-Zamba-218x150.jpg 218w, https://kampalasun.co.ug/wp-content/uploads/2021/03/Ernest-Nsimbi-aka-GNL-Zamba-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="GNL eyes tourism ambassadorial post"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://kampalasun.co.ug/2021/03/10/gnl-eyes-tourism-ambassadorial-post/" rel="bookmark" title="GNL eyes tourism ambassadorial post">GNL eyes tourism ambassadorial post</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://kampalasun.co.ug/2021/03/10/ugandans-react-to-meghan-harry-explosive-interview/" rel="bookmark" class="td-image-wrap" title="Ugandans react to Meghan, Harry explosive interview"><img width="218" height="150" class="entry-thumb" src="https://kampalasun.co.ug/wp-content/uploads/2021/03/prince-harry-meghan-oprah-218x150.jpg" srcset="https://kampalasun.co.ug/wp-content/uploads/2021/03/prince-harry-meghan-oprah-218x150.jpg 218w, https://kampalasun.co.ug/wp-content/uploads/2021/03/prince-harry-meghan-oprah-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Ugandans react to Meghan, Harry explosive interview"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://kampalasun.co.ug/2021/03/10/ugandans-react-to-meghan-harry-explosive-interview/" rel="bookmark" title="Ugandans react to Meghan, Harry explosive interview">Ugandans react to Meghan, Harry explosive interview</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_6049141dce4f6" data-td_block_id="td_uid_1_6049141dce4f6"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_6049141dce4f6" data-td_block_id="td_uid_1_6049141dce4f6"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-mega-menu menu-item-37"><a href="#">Entertainment</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_8_6049141de5a05_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_8_6049141de5a05" ><script>var block_td_uid_8_6049141de5a05 = new tdBlock();
block_td_uid_8_6049141de5a05.id = "td_uid_8_6049141de5a05";
block_td_uid_8_6049141de5a05.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"10","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_8_6049141de5a05_rand","tdc_css_class":"td_uid_8_6049141de5a05_rand","tdc_css_class_style":"td_uid_8_6049141de5a05_rand_style"}';
block_td_uid_8_6049141de5a05.td_column_number = "3";
block_td_uid_8_6049141de5a05.block_type = "td_block_mega_menu";
block_td_uid_8_6049141de5a05.post_count = "5";
block_td_uid_8_6049141de5a05.found_posts = "705";
block_td_uid_8_6049141de5a05.header_color = "";
block_td_uid_8_6049141de5a05.ajax_pagination_infinite_stop = "";
block_td_uid_8_6049141de5a05.max_num_pages = "141";
tdBlocksArray.push(block_td_uid_8_6049141de5a05);
</script><div id=td_uid_8_6049141de5a05 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://kampalasun.co.ug/2021/02/26/i-slaved-for-7-years-without-pay-desire-derekford-mugumisa/" rel="bookmark" class="td-image-wrap" title="I  slaved for 7 years without pay – Desire Derekford Mugumisa"><img width="218" height="150" class="entry-thumb" src="https://kampalasun.co.ug/wp-content/uploads/2021/02/2A82D4FE-F821-464F-99AD-C2FE42B119C0-218x150.jpeg" srcset="https://kampalasun.co.ug/wp-content/uploads/2021/02/2A82D4FE-F821-464F-99AD-C2FE42B119C0-218x150.jpeg 218w, https://kampalasun.co.ug/wp-content/uploads/2021/02/2A82D4FE-F821-464F-99AD-C2FE42B119C0-100x70.jpeg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="I  slaved for 7 years without pay – Desire Derekford Mugumisa"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://kampalasun.co.ug/2021/02/26/i-slaved-for-7-years-without-pay-desire-derekford-mugumisa/" rel="bookmark" title="I  slaved for 7 years without pay – Desire Derekford Mugumisa">I  slaved for 7 years without pay – Desire Derekford&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://kampalasun.co.ug/2021/02/25/pastor-bugingo-tastes-nup-supporters-wrath-over-comments-on-bobi-wines-suv/" rel="bookmark" class="td-image-wrap" title="Pastor Bugingo tastes NUP Supporters wrath over comments on  Bobi Wine’s SUV"><img width="218" height="150" class="entry-thumb" src="https://kampalasun.co.ug/wp-content/uploads/2019/07/Pastor-Bugingo-218x150.png" srcset="https://kampalasun.co.ug/wp-content/uploads/2019/07/Pastor-Bugingo-218x150.png 218w, https://kampalasun.co.ug/wp-content/uploads/2019/07/Pastor-Bugingo-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Pastor Bugingo tastes NUP Supporters wrath over comments on  Bobi Wine’s SUV"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://kampalasun.co.ug/2021/02/25/pastor-bugingo-tastes-nup-supporters-wrath-over-comments-on-bobi-wines-suv/" rel="bookmark" title="Pastor Bugingo tastes NUP Supporters wrath over comments on  Bobi Wine’s SUV">Pastor Bugingo tastes NUP Supporters wrath over comments on  Bobi&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://kampalasun.co.ug/2021/02/19/pr-ssempa-asks-bobi-wine-to-apologise/" rel="bookmark" class="td-image-wrap" title="Pr. Ssempa asks Bobi Wine to apologise"><img width="218" height="150" class="entry-thumb" src="https://kampalasun.co.ug/wp-content/uploads/2021/02/Pr.-Martin-Ssempa-218x150.jpg" srcset="https://kampalasun.co.ug/wp-content/uploads/2021/02/Pr.-Martin-Ssempa-218x150.jpg 218w, https://kampalasun.co.ug/wp-content/uploads/2021/02/Pr.-Martin-Ssempa-100x70.jpg 100w, https://kampalasun.co.ug/wp-content/uploads/2021/02/Pr.-Martin-Ssempa.jpg 640w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Pr. Ssempa asks Bobi Wine to apologise"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://kampalasun.co.ug/2021/02/19/pr-ssempa-asks-bobi-wine-to-apologise/" rel="bookmark" title="Pr. Ssempa asks Bobi Wine to apologise">Pr. Ssempa asks Bobi Wine to apologise</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://kampalasun.co.ug/2021/02/18/fort-portal-journalists-and-rotary-club-celebrate-valentines-day-in-style-donate-blood/" rel="bookmark" class="td-image-wrap" title="Fort Portal journalists and Rotary club celebrate valentine&#8217;s Day in style, donate blood"><img width="218" height="150" class="entry-thumb" src="https://kampalasun.co.ug/wp-content/uploads/2021/02/5-218x150.jpg" srcset="https://kampalasun.co.ug/wp-content/uploads/2021/02/5-218x150.jpg 218w, https://kampalasun.co.ug/wp-content/uploads/2021/02/5-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Fort Portal journalists and Rotary club celebrate valentine&#8217;s Day in style, donate blood"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://kampalasun.co.ug/2021/02/18/fort-portal-journalists-and-rotary-club-celebrate-valentines-day-in-style-donate-blood/" rel="bookmark" title="Fort Portal journalists and Rotary club celebrate valentine&#8217;s Day in style, donate blood">Fort Portal journalists and Rotary club celebrate valentine&#8217;s Day in style,&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://kampalasun.co.ug/2021/02/16/dstv-launches-first-original-pan-african-lifestyle-channel-honey/" rel="bookmark" class="td-image-wrap" title="DStv Launches First Original Pan-African Lifestyle Channel, HONEY"><img width="218" height="150" class="entry-thumb" src="https://kampalasun.co.ug/wp-content/uploads/2021/02/honey1-218x150.jpg" srcset="https://kampalasun.co.ug/wp-content/uploads/2021/02/honey1-218x150.jpg 218w, https://kampalasun.co.ug/wp-content/uploads/2021/02/honey1-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="DStv Launches First Original Pan-African Lifestyle Channel, HONEY"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://kampalasun.co.ug/2021/02/16/dstv-launches-first-original-pan-african-lifestyle-channel-honey/" rel="bookmark" title="DStv Launches First Original Pan-African Lifestyle Channel, HONEY">DStv Launches First Original Pan-African Lifestyle Channel, HONEY</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_8_6049141de5a05" data-td_block_id="td_uid_8_6049141de5a05"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_8_6049141de5a05" data-td_block_id="td_uid_8_6049141de5a05"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-40"><a href="https://kampalasun.co.ug/category/style/">Celebrities</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-41"><a href="https://kampalasun.co.ug/category/travel/">Gossip</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-42"><a href="https://kampalasun.co.ug/category/weird/">Lifestyle</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-286"><a href="https://kampalasun.co.ug/category/celebs/music/">Trending</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-285"><a href="https://kampalasun.co.ug/category/travel/">Travel</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-287"><a href="https://kampalasun.co.ug/category/whats-hot/">Wierd</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-39"><a href="#">Events</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-288"><a href="https://kampalasun.co.ug/category/featured/">Photos</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-289"><a href="https://kampalasun.co.ug/category/featured/">Videos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-mega-menu menu-item-38"><a href="#">Sports</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_9_6049141de8fe3_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_9_6049141de8fe3" ><script>var block_td_uid_9_6049141de8fe3 = new tdBlock();
block_td_uid_9_6049141de8fe3.id = "td_uid_9_6049141de8fe3";
block_td_uid_9_6049141de8fe3.atts = '{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"11","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"preload","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_9_6049141de8fe3_rand","tdc_css_class":"td_uid_9_6049141de8fe3_rand","tdc_css_class_style":"td_uid_9_6049141de8fe3_rand_style"}';
block_td_uid_9_6049141de8fe3.td_column_number = "3";
block_td_uid_9_6049141de8fe3.block_type = "td_block_mega_menu";
block_td_uid_9_6049141de8fe3.post_count = "5";
block_td_uid_9_6049141de8fe3.found_posts = "51";
block_td_uid_9_6049141de8fe3.header_color = "";
block_td_uid_9_6049141de8fe3.ajax_pagination_infinite_stop = "";
block_td_uid_9_6049141de8fe3.max_num_pages = "11";
tdBlocksArray.push(block_td_uid_9_6049141de8fe3);
</script><div id=td_uid_9_6049141de8fe3 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://kampalasun.co.ug/2021/03/09/fashion-revolution-expo-returns-with-new-looks-garden-of-eden/" rel="bookmark" class="td-image-wrap" title="Fashion Revolution expo returns with new looks ‘Garden of Eden’"><img width="218" height="150" class="entry-thumb" src="https://kampalasun.co.ug/wp-content/uploads/2021/03/fash-218x150.jpg" srcset="https://kampalasun.co.ug/wp-content/uploads/2021/03/fash-218x150.jpg 218w, https://kampalasun.co.ug/wp-content/uploads/2021/03/fash-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Fashion Revolution expo returns with new looks ‘Garden of Eden’"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://kampalasun.co.ug/2021/03/09/fashion-revolution-expo-returns-with-new-looks-garden-of-eden/" rel="bookmark" title="Fashion Revolution expo returns with new looks ‘Garden of Eden’">Fashion Revolution expo returns with new looks ‘Garden of Eden’</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://kampalasun.co.ug/2020/12/08/corona-virus-hits-asfas-2020/" rel="bookmark" class="td-image-wrap" title="Corona Virus hits ASFA’S 2020"><img width="218" height="150" class="entry-thumb" src="https://kampalasun.co.ug/wp-content/uploads/2020/12/unnamed-218x150.jpg" srcset="https://kampalasun.co.ug/wp-content/uploads/2020/12/unnamed-218x150.jpg 218w, https://kampalasun.co.ug/wp-content/uploads/2020/12/unnamed-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Corona Virus hits ASFA’S 2020"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://kampalasun.co.ug/2020/12/08/corona-virus-hits-asfas-2020/" rel="bookmark" title="Corona Virus hits ASFA’S 2020">Corona Virus hits ASFA’S 2020</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://kampalasun.co.ug/2020/11/18/miss-uganda-wins-dubai-international-fashion-award/" rel="bookmark" class="td-image-wrap" title="Miss Uganda wins Dubai International fashion award"><img width="218" height="150" class="entry-thumb" src="https://kampalasun.co.ug/wp-content/uploads/2020/11/Olivia-8-218x150.jpg" srcset="https://kampalasun.co.ug/wp-content/uploads/2020/11/Olivia-8-218x150.jpg 218w, https://kampalasun.co.ug/wp-content/uploads/2020/11/Olivia-8-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Miss Uganda wins Dubai International fashion award"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://kampalasun.co.ug/2020/11/18/miss-uganda-wins-dubai-international-fashion-award/" rel="bookmark" title="Miss Uganda wins Dubai International fashion award">Miss Uganda wins Dubai International fashion award</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://kampalasun.co.ug/2020/11/14/2nd-edition-of-the-fashion-revolution-expo-on/" rel="bookmark" class="td-image-wrap" title="2nd Edition of The Fashion Revolution Expo on"><img width="218" height="150" class="entry-thumb" src="https://kampalasun.co.ug/wp-content/uploads/2020/11/A-model-at-the-expo-218x150.jpeg" srcset="https://kampalasun.co.ug/wp-content/uploads/2020/11/A-model-at-the-expo-218x150.jpeg 218w, https://kampalasun.co.ug/wp-content/uploads/2020/11/A-model-at-the-expo-100x70.jpeg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="2nd Edition of The Fashion Revolution Expo on"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://kampalasun.co.ug/2020/11/14/2nd-edition-of-the-fashion-revolution-expo-on/" rel="bookmark" title="2nd Edition of The Fashion Revolution Expo on">2nd Edition of The Fashion Revolution Expo on</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://kampalasun.co.ug/2020/09/17/corona-virus-hits-beauty-pageants/" rel="bookmark" class="td-image-wrap" title="Corona Virus hits beauty pageants "><img width="218" height="150" class="entry-thumb" src="https://kampalasun.co.ug/wp-content/uploads/2020/09/AVDMANUSHI-218x150.jpg" srcset="https://kampalasun.co.ug/wp-content/uploads/2020/09/AVDMANUSHI-218x150.jpg 218w, https://kampalasun.co.ug/wp-content/uploads/2020/09/AVDMANUSHI-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Corona Virus hits beauty pageants "/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://kampalasun.co.ug/2020/09/17/corona-virus-hits-beauty-pageants/" rel="bookmark" title="Corona Virus hits beauty pageants ">Corona Virus hits beauty pageants </a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_9_6049141de8fe3" data-td_block_id="td_uid_9_6049141de8fe3"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_9_6049141de8fe3" data-td_block_id="td_uid_9_6049141de8fe3"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
</ul></div></div>            </div>
        </div>
    </div>

    
</div><div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://kampalasun.co.ug/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Celebs" class="entry-crumb" href="https://kampalasun.co.ug/category/celebs/">Celebs</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Hollywood" class="entry-crumb" href="https://kampalasun.co.ug/category/celebs/hollywood/">Hollywood</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Ugandans react to Meghan, Harry explosive interview</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-10314" class="post-10314 post type-post status-publish format-standard has-post-thumbnail hentry category-hollywood tag-harry-meghan" itemscope itemtype="https://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  href="https://kampalasun.co.ug/category/celebs/">Celebs</a></li><li class="entry-category"><a  href="https://kampalasun.co.ug/category/celebs/hollywood/">Hollywood</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Ugandans react to Meghan, Harry explosive interview</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://kampalasun.co.ug/author/klasun_admin/">klasun_admin</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-03-10T06:53:58+00:00" >March 10, 2021</time></span>                    <div class="td-post-comments"><a href="https://kampalasun.co.ug/2021/03/10/ugandans-react-to-meghan-harry-explosive-interview/#respond"><i class="td-icon-comments"></i>0</a></div>                    <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-10314">84</span></div>                </div>

            </header>

        </div>

        <div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkampalasun.co.ug%2F2021%2F03%2F10%2Fugandans-react-to-meghan-harry-explosive-interview%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Ugandans+react+to+Meghan%2C+Harry+explosive+interview&url=https%3A%2F%2Fkampalasun.co.ug%2F2021%2F03%2F10%2Fugandans-react-to-meghan-harry-explosive-interview%2F&via=Kampala+Sun">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-googleplus" href="https://plus.google.com/share?url=https://kampalasun.co.ug/2021/03/10/ugandans-react-to-meghan-harry-explosive-interview/">
                                        <div class="td-social-but-icon"><i class="td-icon-googleplus"></i></div>
                                        <div class="td-social-but-text">Google+</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://kampalasun.co.ug/2021/03/10/ugandans-react-to-meghan-harry-explosive-interview/&amp;media=https://kampalasun.co.ug/wp-content/uploads/2021/03/prince-harry-meghan-oprah.jpg&description=Ugandans+react+to+Meghan%2C+Harry+explosive+interview">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Ugandans react to Meghan, Harry explosive interview %0A%0A https://kampalasun.co.ug/2021/03/10/ugandans-react-to-meghan-harry-explosive-interview/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>

        <div class="td-post-content">

        <div class="td-post-featured-image"><a href="https://kampalasun.co.ug/wp-content/uploads/2021/03/prince-harry-meghan-oprah.jpg" data-caption=""><img width="696" height="365" class="entry-thumb td-modal-image" src="https://kampalasun.co.ug/wp-content/uploads/2021/03/prince-harry-meghan-oprah-696x365.jpg" srcset="https://kampalasun.co.ug/wp-content/uploads/2021/03/prince-harry-meghan-oprah-696x365.jpg 696w, https://kampalasun.co.ug/wp-content/uploads/2021/03/prince-harry-meghan-oprah-300x158.jpg 300w, https://kampalasun.co.ug/wp-content/uploads/2021/03/prince-harry-meghan-oprah-1024x538.jpg 1024w, https://kampalasun.co.ug/wp-content/uploads/2021/03/prince-harry-meghan-oprah-768x403.jpg 768w, https://kampalasun.co.ug/wp-content/uploads/2021/03/prince-harry-meghan-oprah-1068x561.jpg 1068w, https://kampalasun.co.ug/wp-content/uploads/2021/03/prince-harry-meghan-oprah-800x420.jpg 800w, https://kampalasun.co.ug/wp-content/uploads/2021/03/prince-harry-meghan-oprah.jpg 1200w" sizes="(max-width: 696px) 100vw, 696px" alt="" title="prince-harry-meghan-oprah"/></a></div>
        
<p><strong>By Ahmad Muto</strong><strong></strong></p>



<p>Ugandans
 have reacted to the ongoing drama on social media and
the press following the former Duke and Duchess of Sussex’s Meghan 
Markle and Harry&#8217;s explosive sit down with
media personality, Oprah Winfrey. In the interview, one particular issue
 stood
out – racism where Markle stated that at some point she even considered
suicide because like in the Palace had become unbearable. She also said 
the probable skin colour of their baby bothered the Palace alot&nbsp;while 
pregnant.</p>



<p>It
 is important to note that Ugandans aren’t as divided as he British, 
Americans and the rest of the world. They majorly localized it by
bringing it down to tribes and cultures here, asking if it is any 
different with people of
different tribes get together. A section argued that some people 
commenting on
the issue are the very one that have made lives married into their 
families unbearable,
and therefore this is a chance to reflect. </p>



<p>@Tumusiime _ug: “I just don&#8217;t get how some of you my
Ugandan friends are all surprised that the British Royal Family had a problem
accepting Meghan Markle, a black woman. If Kabaka Mutebi had tried to marry a
Japanese Lady or the Kyabazinga, a white lady, y&#8217;all would get it. It will TAKE
TIME!”</p>



<p>@Davisnganzi replied: “My brother u r going to far, just
look at Tooro kingdom, wen they realised their princess was going to some Black
American. They ranted fr the whole year, proposing men who she should have
married instead. M sure some of them even went to some gods for the marriage
not to work.”</p>



<p>@Drei_OX tweeted: “I see you people acting all good and shocked about this interview but the women married into your family can not breathe because of you, your parents and your siblings.”</p>



<p><strong>Twitter: @MUTOHD</strong></p>
<div style="position:absolute; top:0; left:-9999px;"><a href="https://www.thewpclub.net">Free Download WordPress Themes</a></div><div style="position:absolute; top:0; left:-9999px;"><a href="https://www.themeslide.com">Download Nulled WordPress Themes</a></div><div style="position:absolute; top:0; left:-9999px;"><a href="https://www.script-stack.com">Download WordPress Themes</a></div><div style="position:absolute; top:0; left:-9999px;"><a href="https://www.thememazing.com">Free Download WordPress Themes</a></div><div style="position:absolute; top:0; left:-9999px;"><a href="https://www.onlinefreecourse.net">free download udemy course</a></div><div style="position:absolute; top:0; left:-9999px;"><a href="https://www.frendx.com/firmware/">download lava firmware</a></div><div style="position:absolute; top:0; left:-9999px;"><a href="https://www.themebanks.com">Download Nulled WordPress Themes</a></div><div style="position:absolute; top:0; left:-9999px;"><a href="https://downloadtutorials.net">download udemy paid course for free</a></div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://kampalasun.co.ug/tag/harry-meghan/">Harry Meghan</a></li></ul>            </div>

            <div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://kampalasun.co.ug/2021/03/10/ugandans-react-to-meghan-harry-explosive-interview/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkampalasun.co.ug%2F2021%2F03%2F10%2Fugandans-react-to-meghan-harry-explosive-interview%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Ugandans+react+to+Meghan%2C+Harry+explosive+interview&url=https%3A%2F%2Fkampalasun.co.ug%2F2021%2F03%2F10%2Fugandans-react-to-meghan-harry-explosive-interview%2F&via=Kampala+Sun">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-googleplus" href="https://plus.google.com/share?url=https://kampalasun.co.ug/2021/03/10/ugandans-react-to-meghan-harry-explosive-interview/">
                                        <div class="td-social-but-icon"><i class="td-icon-googleplus"></i></div>
                                        <div class="td-social-but-text">Google+</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://kampalasun.co.ug/2021/03/10/ugandans-react-to-meghan-harry-explosive-interview/&amp;media=https://kampalasun.co.ug/wp-content/uploads/2021/03/prince-harry-meghan-oprah.jpg&description=Ugandans+react+to+Meghan%2C+Harry+explosive+interview">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Ugandans react to Meghan, Harry explosive interview %0A%0A https://kampalasun.co.ug/2021/03/10/ugandans-react-to-meghan-harry-explosive-interview/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://kampalasun.co.ug/2021/03/10/mr-eezy-on-the-spot-over-stolen-song/">Mr.Eezy on the spot over stolen song</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://kampalasun.co.ug/2021/03/10/gnl-eyes-tourism-ambassadorial-post/">GNL eyes tourism ambassadorial post</a></div></div></div>            <div class="author-box-wrap"><a href="https://kampalasun.co.ug/author/klasun_admin/"><img alt='' src='https://secure.gravatar.com/avatar/eaf1e1506ea2dbcf056d1647ffbfa933?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/eaf1e1506ea2dbcf056d1647ffbfa933?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://kampalasun.co.ug/author/klasun_admin/">klasun_admin</a></span></div><div class="td-author-description"></div><div class="td-author-social"></div><div class="clearfix"></div></div></div>	        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="klasun_admin"></span><meta itemprop="datePublished" content="2021-03-10T06:53:58+00:00"><meta itemprop="dateModified" content="2021-03-10T06:54:00+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://kampalasun.co.ug/2021/03/10/ugandans-react-to-meghan-harry-explosive-interview/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://kampalasun.co.ug/wp-content/uploads/2019/06/Sun-Logo-1-300x183.png"></span><meta itemprop="name" content="Kampala Sun"></span><meta itemprop="headline " content="Ugandans react to Meghan, Harry explosive interview"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://kampalasun.co.ug/wp-content/uploads/2021/03/prince-harry-meghan-oprah.jpg"><meta itemprop="width" content="1200"><meta itemprop="height" content="630"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_11_6049141deec22_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_11_6049141deec22" ><script>var block_td_uid_11_6049141deec22 = new tdBlock();
block_td_uid_11_6049141deec22.id = "td_uid_11_6049141deec22";
block_td_uid_11_6049141deec22.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_11_6049141deec22_rand","td_column_number":3,"live_filter_cur_post_id":10314,"live_filter_cur_post_author":"1","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_11_6049141deec22_rand","tdc_css_class_style":"td_uid_11_6049141deec22_rand_style"}';
block_td_uid_11_6049141deec22.td_column_number = "3";
block_td_uid_11_6049141deec22.block_type = "td_block_related_posts";
block_td_uid_11_6049141deec22.post_count = "3";
block_td_uid_11_6049141deec22.found_posts = "41";
block_td_uid_11_6049141deec22.header_color = "";
block_td_uid_11_6049141deec22.ajax_pagination_infinite_stop = "";
block_td_uid_11_6049141deec22.max_num_pages = "14";
tdBlocksArray.push(block_td_uid_11_6049141deec22);
</script><h4 class="td-related-title td-block-title"><a id="td_uid_12_6049141def332" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_11_6049141deec22" href="#">RELATED ARTICLES</a><a id="td_uid_13_6049141def336" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_11_6049141deec22" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_11_6049141deec22 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://kampalasun.co.ug/2021/02/24/kaluuya-reveals-he-wasnt-invited-to-get-out-movie-premiere/" rel="bookmark" class="td-image-wrap" title="Kaluuya reveals he wasn’t invited to Get Out movie premiere"><img width="218" height="150" class="entry-thumb" src="https://kampalasun.co.ug/wp-content/uploads/2021/02/daniel-kaluuya-218x150.jpg" srcset="https://kampalasun.co.ug/wp-content/uploads/2021/02/daniel-kaluuya-218x150.jpg 218w, https://kampalasun.co.ug/wp-content/uploads/2021/02/daniel-kaluuya-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Kaluuya reveals he wasn’t invited to Get Out movie premiere"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://kampalasun.co.ug/2021/02/24/kaluuya-reveals-he-wasnt-invited-to-get-out-movie-premiere/" rel="bookmark" title="Kaluuya reveals he wasn’t invited to Get Out movie premiere">Kaluuya reveals he wasn’t invited to Get Out movie premiere</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://kampalasun.co.ug/2021/02/23/netflix-to-modify-lupita-nyongos-story-book-sulwe-into-animated-movie/" rel="bookmark" class="td-image-wrap" title="Netflix to modify Lupita Nyong&#8217;o’s story book “Sulwe” into animated movie"><img width="218" height="150" class="entry-thumb" src="https://kampalasun.co.ug/wp-content/uploads/2021/02/lupita-218x150.jpg" srcset="https://kampalasun.co.ug/wp-content/uploads/2021/02/lupita-218x150.jpg 218w, https://kampalasun.co.ug/wp-content/uploads/2021/02/lupita-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Netflix to modify Lupita Nyong&#8217;o’s story book “Sulwe” into animated movie"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://kampalasun.co.ug/2021/02/23/netflix-to-modify-lupita-nyongos-story-book-sulwe-into-animated-movie/" rel="bookmark" title="Netflix to modify Lupita Nyong&#8217;o’s story book “Sulwe” into animated movie">Netflix to modify Lupita Nyong&#8217;o’s story book “Sulwe” into animated movie</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://kampalasun.co.ug/2021/02/05/daniel-kaluuya-receives-golden-globe-nomination/" rel="bookmark" class="td-image-wrap" title="Daniel Kaluuya receives Golden Globe nomination"><img width="218" height="150" class="entry-thumb" src="https://kampalasun.co.ug/wp-content/uploads/2021/02/daniel-kaluuya-218x150.jpg" srcset="https://kampalasun.co.ug/wp-content/uploads/2021/02/daniel-kaluuya-218x150.jpg 218w, https://kampalasun.co.ug/wp-content/uploads/2021/02/daniel-kaluuya-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Daniel Kaluuya receives Golden Globe nomination"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://kampalasun.co.ug/2021/02/05/daniel-kaluuya-receives-golden-globe-nomination/" rel="bookmark" title="Daniel Kaluuya receives Golden Globe nomination">Daniel Kaluuya receives Golden Globe nomination</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_11_6049141deec22" data-td_block_id="td_uid_11_6049141deec22"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_11_6049141deec22" data-td_block_id="td_uid_11_6049141deec22"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
	<div class="comments" id="comments">
        	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/03/10/ugandans-react-to-meghan-harry-explosive-interview/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://kampalasun.co.ug/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="clearfix"></div>
				<div class="comment-form-input-wrap td-form-comment">
					<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
					<div class="td-warning-comment">Please enter your comment!</div>
				</div>
		        <div class="comment-form-input-wrap td-form-author">
			            <input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-author">Please enter your name here</div>
			         </div>
<div class="comment-form-input-wrap td-form-email">
			            <input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-email-error">You have entered an incorrect email address!</div>
			            <div class="td-warning-email">Please enter your email address here</div>
			         </div>
<div class="comment-form-input-wrap td-form-url">
			            <input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" />
                     </div>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='10314' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form>	</div><!-- #respond -->
	    </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                                <!-- .no sidebar -->
                                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->



	<div class="td-footer-wrapper td-footer-page td-container-wrap">
	<p><div id="td_uid_1_6049141df0d4f" class="tdc-row stretch_row_1600 td-stretch-content"><div class="vc_row td_uid_14_6049141df0d58_rand  wpb_row td-pb-row tdc-element-style" >
<style scoped>

/* custom css */
.td_uid_14_6049141df0d58_rand {
                    min-height: 0;
                }
/* inline tdc_css att */

.td_uid_14_6049141df0d58_rand{
padding-top:60px !important;
padding-bottom:60px !important;
position:relative;
}

.td_uid_14_6049141df0d58_rand .td_block_wrap{ text-align:left }

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.td_uid_14_6049141df0d58_rand{
padding-top:40px !important;
padding-bottom:40px !important;
}
}

</style>
<div class="td_uid_1_6049141df0d4f_rand_style td-element-style" style="opacity: 0; transition: opacity 1s;"><style>
.td_uid_1_6049141df0d4f_rand_style{
background-color:#ededed !important;
}
 </style></div><div class="vc_column td_uid_15_6049141df1210_rand  wpb_column vc_column_container tdc-column td-pb-span4"><div class="wpb_wrapper"><div class="tdm_block td_block_wrap tdm_block_column_title td_uid_16_6049141df1388_rand tdm-content-horiz-center td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_16_6049141df1388" >
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.td_uid_16_6049141df1388_rand{
justify-content:center !important;
text-align:center !important;
}
}

</style><div class="td-block-row"><div class="td-block-span12 tdm-col">
<style>
body .td_uid_17_6049141df26ec .tdm-title {
					color: #222222;
				}
				
				.td_uid_17_6049141df26ec .tdm-title {
					font-family:Fira Sans !important;font-size:36px !important;line-height:1 !important;font-style:italic !important;font-weight:700 !important;
				}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.td_uid_17_6049141df26ec .tdm-title {
					font-family:Fira Sans !important;font-size:30px !important;line-height:1 !important;font-style:italic !important;font-weight:700 !important;
				}
}
</style><div class="tds-title tds-title1 td-fix-index td_uid_17_6049141df26ec"><h3 class="tdm-title tdm-title-md">The Kampala Sun</h3></div></div></div></div><div class="tdm_block td_block_wrap tdm_block_inline_text td_uid_18_6049141df2b06_rand tdm-content-horiz-left td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_18_6049141df2b06" >
<style>

/* inline tdc_css att */

.td_uid_18_6049141df2b06_rand{
margin-top:-10px !important;
margin-bottom:0px !important;
padding-right:80px !important;
}

/* landscape */
@media (min-width: 1019px) and (max-width: 1140px)
{
.td_uid_18_6049141df2b06_rand{
padding-right:20px !important;
}
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.td_uid_18_6049141df2b06_rand{
padding-right:20px !important;
}
}

/* phone */
@media (max-width: 767px)
{
.td_uid_18_6049141df2b06_rand{
margin-bottom:30px !important;
padding-right:0px !important;
justify-content:center !important;
text-align:center !important;
}
}

</style>
<style>
/* custom css */
.td_uid_18_6049141df2b06_rand .tdm-descr {
                    color: #444444;
                }
                
				.td_uid_18_6049141df2b06_rand .tdm-descr {
					font-family:Fira Sans !important;font-size:14px !important;line-height:1.5 !important;font-style:italic !important;
				}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.td_uid_18_6049141df2b06_rand .tdm-descr {
					font-family:Fira Sans !important;font-size:12px !important;line-height:1.5 !important;font-style:italic !important;
				}
}
</style><p class="tdm-descr">Kampala Sun gives you the latest news on celebrities and in entertainment. You can't afford to miss the latest in sports and other social events happening in Kampala, in and around Uganda. 
Briefly, YOU CAN'T READ IT ALONE</p></div></div></div><div class="vc_column td_uid_19_6049141e008d8_rand  wpb_column vc_column_container tdc-column td-pb-span4"><div class="wpb_wrapper"><div class="tdm_block td_block_wrap tdm_block_column_title td_uid_20_6049141e00977_rand tdm-content-horiz-center td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_20_6049141e00977" ><div class="td-block-row"><div class="td-block-span12 tdm-col">
<style>
body .td_uid_21_6049141e02602 .tdm-title {
					color: #222222;
				}
				
				.td_uid_21_6049141e02602 .tdm-title {
					font-family:Fira Sans !important;font-size:20px !important;line-height:1 !important;font-style:italic !important;font-weight:700 !important;text-transform:uppercase !important;
				}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.td_uid_21_6049141e02602 .tdm-title {
					font-family:Fira Sans !important;font-size:16px !important;line-height:1 !important;font-style:italic !important;font-weight:700 !important;text-transform:uppercase !important;
				}
}
</style><div class="tds-title tds-title1 td-fix-index td_uid_21_6049141e02602"><h3 class="tdm-title tdm-title-md">Quick Links</h3></div></div></div></div><div class="td_block_wrap td_block_list_menu td_uid_22_6049141e02a3b_rand td-pb-border-top td_block_template_1 widget"  data-td-block-uid="td_uid_22_6049141e02a3b" >
<style>

/* inline tdc_css att */

.td_uid_22_6049141e02a3b_rand{
margin-bottom:0px !important;
}

/* phone */
@media (max-width: 767px)
{
.td_uid_22_6049141e02a3b_rand{
margin-bottom:30px !important;
}
}

</style>
<style>
/* custom css */
.td_uid_22_6049141e02a3b_rand li {
					display: inline-block;
				}
				
				.td_uid_22_6049141e02a3b_rand ul {
					margin: 0px;
				}
				
				.td_uid_22_6049141e02a3b_rand ul li {
					margin-right: 20px;
				}
				
				.td_uid_22_6049141e02a3b_rand ul {
					text-align: center;
				}
				

                
				.td_uid_22_6049141e02a3b_rand a {
					color: #222222;
				}
				
				.td_uid_22_6049141e02a3b_rand li {
					font-style:italic !important;font-weight:700 !important;
				}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.td_uid_22_6049141e02a3b_rand li {
					font-size:12px !important;font-style:italic !important;font-weight:700 !important;
				}
}
</style><div class="td-block-title-wrap"></div><div id=td_uid_22_6049141e02a3b class="td_block_inner td-fix-index"></div></div> <!-- ./block --></div></div><div class="vc_column td_uid_23_6049141e02e04_rand  wpb_column vc_column_container tdc-column td-pb-span4"><div class="wpb_wrapper"><div class="tdm_block td_block_wrap tdm_block_column_title td_uid_24_6049141e02eb2_rand tdm-content-horiz-center td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_24_6049141e02eb2" ><div class="td-block-row"><div class="td-block-span12 tdm-col">
<style>
body .td_uid_25_6049141e04b2e .tdm-title {
					color: #222222;
				}
				
				.td_uid_25_6049141e04b2e .tdm-title {
					font-family:Fira Sans !important;font-size:20px !important;line-height:1 !important;font-style:italic !important;font-weight:700 !important;text-transform:uppercase !important;
				}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.td_uid_25_6049141e04b2e .tdm-title {
					font-family:Fira Sans !important;font-size:16px !important;line-height:1 !important;font-style:italic !important;font-weight:700 !important;text-transform:uppercase !important;
				}
}
</style><div class="tds-title tds-title1 td-fix-index td_uid_25_6049141e04b2e"><h3 class="tdm-title tdm-title-md">Follow Us</h3></div></div></div></div><div class="tdm_block td_block_wrap tdm_block_socials td_uid_26_6049141e04ec0_rand tdm-content-horiz-center td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_26_6049141e04ec0" >
<style>

/* inline tdc_css att */

.td_uid_26_6049141e04ec0_rand{
margin-top:-5px !important;
margin-bottom:0px !important;
}

</style>
<style>
.td_uid_27_6049141e06c5d .tdm-social-item i {
					font-size: 15px;
					vertical-align: middle;
				}
				.td_uid_27_6049141e06c5d .tdm-social-item i.td-icon-twitter,
				.td_uid_27_6049141e06c5d .tdm-social-item i.td-icon-linkedin,
				.td_uid_27_6049141e06c5d .tdm-social-item i.td-icon-pinterest,
				.td_uid_27_6049141e06c5d .tdm-social-item i.td-icon-blogger,
				.td_uid_27_6049141e06c5d .tdm-social-item i.td-icon-vimeo {
					font-size: 12px;
				}
				
				.td_uid_27_6049141e06c5d .tdm-social-item {
					width: 40.5px;
					height: 40.5px;
					line-height: 40.5px;
				}
				
				.td_uid_27_6049141e06c5d .tdm-social-item {
				    margin: 5px 10px 5px 0;
				}
				
				.td_uid_27_6049141e06c5d .tdm-social-item-wrap:last-child .tdm-social-item {
				    margin-right: 0 !important;
				}
                
				.td_uid_27_6049141e06c5d .tdm-social-item {
					border-radius: 50px;
				}
				
				
                
				.td_uid_27_6049141e06c5d .tdm-social-text {
					margin-left: 2px;
				}
                
				.td_uid_27_6049141e06c5d .tdm-social-text {
					margin-right: 18px;
				}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.td_uid_27_6049141e06c5d .tdm-social-item i {
					font-size: 14px;
					vertical-align: middle;
				}
				.td_uid_27_6049141e06c5d .tdm-social-item i.td-icon-twitter,
				.td_uid_27_6049141e06c5d .tdm-social-item i.td-icon-linkedin,
				.td_uid_27_6049141e06c5d .tdm-social-item i.td-icon-pinterest,
				.td_uid_27_6049141e06c5d .tdm-social-item i.td-icon-blogger,
				.td_uid_27_6049141e06c5d .tdm-social-item i.td-icon-vimeo {
					font-size: 11.2px;
				}
				
				.td_uid_27_6049141e06c5d .tdm-social-item {
					width: 33.6px;
					height: 33.6px;
					line-height: 33.6px;
				}
				
				.td_uid_27_6049141e06c5d .tdm-social-item {
				    margin: 2.5px 5px 2.5px 0;
				}
}
</style><div class="tdm-social-wrapper tds-social3 td_uid_27_6049141e06c5d"><div class="tdm-social-item-wrap"><a href="#" class="tdm-social-item"><i class="td-icon-font td-icon-facebook"></i></a><a href="#" class="tdm-social-text">Facebook</a></div><div class="tdm-social-item-wrap"><a href="#" class="tdm-social-item"><i class="td-icon-font td-icon-googleplus"></i></a><a href="#" class="tdm-social-text">Google+</a></div><div class="tdm-social-item-wrap"><a href="#" class="tdm-social-item"><i class="td-icon-font td-icon-instagram"></i></a><a href="#" class="tdm-social-text">Instagram</a></div><div class="tdm-social-item-wrap"><a href="#" class="tdm-social-item"><i class="td-icon-font td-icon-twitter"></i></a><a href="#" class="tdm-social-text">Twitter</a></div><div class="tdm-social-item-wrap"><a href="#" class="tdm-social-item"><i class="td-icon-font td-icon-youtube"></i></a><a href="#" class="tdm-social-text">Youtube</a></div></div></div></div></div></div></div>
		<script>

			jQuery(window).load(function () {
				jQuery('body').find('#td_uid_1_6049141df0d4f .td-element-style').each(function (index, element) {
					jQuery(element).css('opacity', 1);
					return;
				});
			});

		</script>

		
			<script>

				jQuery(window).ready(function () {

					// We need timeout because the content must be rendered and interpreted on client
					setTimeout(function () {

						var $content = jQuery('body').find('#tdc-live-iframe'),
							refWindow = undefined;

						if ($content.length) {
							$content = $content.contents();
							refWindow = document.getElementById('tdc-live-iframe').contentWindow || document.getElementById('tdc-live-iframe').contentDocument;

						} else {
							$content = jQuery('body');
							refWindow = window;
						}

						$content.find('#td_uid_1_6049141df0d4f .td-element-style').each(function (index, element) {
							jQuery(element).css('opacity', 1);
							return;
						});
					});

				}, 200);
			</script>

			</p>
<div style="position:absolute; top:0; left:-9999px;"><a href="https://www.thewpclub.net">Download WordPress Themes</a></div>
<div style="position:absolute; top:0; left:-9999px;"><a href="https://www.themeslide.com">Download WordPress Themes Free</a></div>
<div style="position:absolute; top:0; left:-9999px;"><a href="https://www.script-stack.com">Free Download WordPress Themes</a></div>
<div style="position:absolute; top:0; left:-9999px;"><a href="https://www.thememazing.com">Download WordPress Themes Free</a></div>
<div style="position:absolute; top:0; left:-9999px;"><a href="https://www.onlinefreecourse.net">udemy paid course free download</a></div>
<div style="position:absolute; top:0; left:-9999px;"><a href="https://www.frendx.com/firmware/">download xiomi firmware</a></div>
<div style="position:absolute; top:0; left:-9999px;"><a href="https://www.themebanks.com">Download WordPress Themes</a></div>
<div style="position:absolute; top:0; left:-9999px;"><a href="https://downloadtutorials.net">udemy paid course free download</a></div>
	</div>



</div><!--close td-outer-wrap-->



    <!--

        Theme: Newspaper by tagDiv.com 2017
        Version: 9.1 (rara)
        Deploy mode: deploy
        
        uid: 6049141e07377
    -->

    <script type='text/javascript' src='https://kampalasun.co.ug/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=9.1'></script>
<script type='text/javascript' src='https://kampalasun.co.ug/wp-includes/js/comment-reply.min.js?ver=5.3.6'></script>
<script type='text/javascript' src='https://kampalasun.co.ug/wp-includes/js/wp-embed.min.js?ver=5.3.6'></script>

<!-- JS generated by theme -->

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://kampalasun.co.ug/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://kampalasun.co.ug/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>



			<div id="tdw-css-writer" style="display: none" class="tdw-drag-dialog tdc-window-sidebar">
				<header>

				
					<a title="Editor" class="tdw-tab tdc-tab-active" href="#" data-tab-content="tdw-tab-editor">Edit with Live CSS</a>
					<div class="tdw-less-info" title="This will be red when errors are detected in your CSS and LESS"></div>
				
				</header>
				<div class="tdw-content">

					
					<div class="tdw-tabs-content tdw-tab-editor tdc-tab-content-active">


						<script>

							(function(jQuery, undefined) {

								jQuery(window).ready(function() {

									if ( 'undefined' !== typeof tdcAdminIFrameUI ) {
										var $liveIframe  = tdcAdminIFrameUI.getLiveIframe();

										if ( $liveIframe.length ) {
											$liveIframe.load(function() {
												$liveIframe.contents().find( 'body').append( '<textarea class="tdw-css-writer-editor" style="display: none"></textarea>' );
											});
										}
									}

								});

							})(jQuery);

						</script>


						<textarea class="tdw-css-writer-editor td_live_css_uid_1_6049141e074f4"></textarea>
						<div id="td_live_css_uid_1_6049141e074f4" class="td-code-editor"></div>


						<script>
							jQuery(window).load(function (){

								if ( 'undefined' !== typeof tdLiveCssInject ) {

									tdLiveCssInject.init();


									var editor_textarea = jQuery('.td_live_css_uid_1_6049141e074f4');
									var languageTools = ace.require("ace/ext/language_tools");
									var tdcCompleter = {
										getCompletions: function (editor, session, pos, prefix, callback) {
											if (prefix.length === 0) {
												callback(null, []);
												return
											}

											if ('undefined' !== typeof tdcAdminIFrameUI) {

												var data = {
													error: undefined,
													getShortcode: ''
												};

												tdcIFrameData.getShortcodeFromData(data);

												if (!_.isUndefined(data.error)) {
													tdcDebug.log(data.error);
												}

												if (!_.isUndefined(data.getShortcode)) {

													var regex = /el_class=\"([A-Za-z0-9_-]*\s*)+\"/g,
														results = data.getShortcode.match(regex);

													var elClasses = {};

													for (var i = 0; i < results.length; i++) {
														var currentClasses = results[i]
															.replace('el_class="', '')
															.replace('"', '')
															.split(' ');

														for (var j = 0; j < currentClasses.length; j++) {
															if (_.isUndefined(elClasses[currentClasses[j]])) {
																elClasses[currentClasses[j]] = '';
															}
														}
													}

													var arrElClasses = [];

													for (var prop in elClasses) {
														arrElClasses.push(prop);
													}

													callback(null, arrElClasses.map(function (item) {
														return {
															name: item,
															value: item,
															meta: 'in_page'
														}
													}));
												}
											}
										}
									};
									languageTools.addCompleter(tdcCompleter);

									window.editor = ace.edit("td_live_css_uid_1_6049141e074f4");
                                    window.editor.$blockScrolling = Infinity;

                                    // 'change' handler is written as function because it's called by tdc_on_add_css_live_components (of wp_footer hook)
									// We did it to reattach the existing compiled css to the new content received from server.
									window.editorChangeHandler = function () {
										//tdwState.lessWasEdited = true;

										window.onbeforeunload = function () {
											if (tdwState.lessWasEdited) {
												return "You have attempted to leave this page. Are you sure?";
											}
											return false;
										};

										var editorValue = editor.getSession().getValue();

										editor_textarea.val(editorValue);

										if ('undefined' !== typeof tdcAdminIFrameUI) {
											tdcAdminIFrameUI.getLiveIframe().contents().find('.tdw-css-writer-editor:first').val(editorValue);

											// Mark the content as modified
											// This is important for showing info when composer closes
                                            tdcMain.setContentModified();
										}

										tdLiveCssInject.less();
									};

									editor.getSession().setValue(editor_textarea.val());
									editor.getSession().on('change', editorChangeHandler);

									editor.setTheme("ace/theme/textmate");
									editor.setShowPrintMargin(false);
									editor.getSession().setMode("ace/mode/less");
                                    editor.getSession().setUseWrapMode(true);
									editor.setOptions({
										enableBasicAutocompletion: true,
										enableSnippets: true,
										enableLiveAutocompletion: false
									});

								}

							});
						</script>

					</div>
				</div>

				<footer>

					
						<a href="#" class="tdw-save-css">Save</a>
						<div class="tdw-more-info-text">Write CSS OR LESS and hit save. CTRL + SPACE for auto-complete.</div>

					
					<div class="tdw-resize"></div>
				</footer>
			</div>
			
</body>
</html>